.NET Core supported technologies

We support the following technologies for this agent.

Technology

Supported versions

Notes

Application frameworks

ASP.NET Core (3.1.X, 5.0.X, 6.0.X)

Not supported:

  • .NET Core or ASP.NET Core version 2.1 or below

  • ASP.NET Core applications running under the .NET Framework (Windows) or Mono (Linux/Windows)

Runtime

  • .NET Core Runtimes: 3.1.X, 5.0.X, 6.0.X

  • .NET Core target framework monikers:

    netcoreapp3.1

    net5.0

    net6.0

Not supported:

  • Running with an ASP.NET Core application that's a higher version than the runtime (for example, an application with the .NET Core 3.1 runtime that references ASP.NET Core 5.0)

  • Running with a .NET Core application for which the referenced ASP.NET Core version and the target runtime selected during compilation time don't match

.NET Core for Windows

Windows operating systems

  • Windows Server (LTSC) (x86, x64): 2008 R2, 2012, 2012 R2, 2016, 2019

  • Windows Server (SAC) (x64): 1809, 1903

  • Windows workstation (x86, x64): 7, 8/8.1, 10

On 64-bit systems, you can use the agent to analyze both 32-bit and 64-bit web applications.

Not supported:

  • Windows on ARM

Server container

Kestrel, IISHttpServer

Not supported:

Http.sys (formerly called WebListener)

Hosting container

Self-hosted, IIS, IIS Express

.NET Core for Linux

Linux operating systems

  • Ubuntu: 16.04 and later

  • Debian: 9 and later

  • openSUSE: 15 and later

  • Alpine: 3.7 and later

  • CentOS: 7 and later

  • Red Hat Enterprise Linux: 7, 8

All systems require x64 architectures.

Not supported: Red Hat Enterprise Linux 6

Server container

Kestrel

Hosting container

Self-hosted

Important

.NET Core 2.2 is not supported after the .NET core agent version 1.5.20. If you are using .NET Core 2.2, you'll need to use .NET Core agent version 1.5.20 or lower until you can upgrade your application’s .NET Core runtime.

As of .NET core agent version 1.9.9, we no longer support .NET Core 2.1. If you are using .NET Core 2.1, you'll need to use .NET Core agent version 1.9.9 or lower until you can upgrade your application’s .NET Core runtime.

Note

The .NET Core agent does not support applications that do not reference System.Runtime and ASPNET Core. The agent also does not support trimmed self-contained deployments and executables, because the compiler can potentially trim assemblies that the agent depends on.